This page was exported from phaq [ http://phaq.phunsites.net ]
Export date: Fri Apr 19 21:16:16 2019 / +0000 GMT
Wie bereits aufgezeigt, kann man statt dem Centro Grande oder Centro Piccolo auch problemlos einen Cisco 892F an einem Swisscom Vivo FTTH-Anschluss betreiben.

Hat man diese Hürde erstmal geschafft, möchte man den Cisco vielleicht am Swisscom-eigenen IPv6 6RD Gateway anbinden um in den Genuss von IPv6 zu kommen.


! Wichtige Information !

Die IP-Adresse des Swisscom 6RD Relays ändert per 9. April 2013:

193.5.29.1




Klar, man kann dafür natürlich auch auf einen IPv6 Tunnel Broker wie SIXXS oder Hurricane Electric verwenden, doch wozu in die Ferne schweifen, wenn man den Gateway quasi vor der Haustüre hat?

Es sei dazu höchstens noch anzumerken, dass 6RD nicht ganz dasselbe ist wie ein Teredo, ISATAP or 6to4 Tunnel, obwohl alle Varianten letztlich zum Ziel haben eine IPv6-Anbindung über IPv4-Netze hinweg zu ermöglichen.
Wer zum Beispiel seinen "eigenen" IPv6 Prefix zu sich nach hause tunneln möchte, ist mit einem Tunnel Broker besser bedient. 6RD weist nämlich ausschliesslich Adressen aus dem Swisscom-eigenen 6RD-Pool zu. Wenn allerdings nur die reine Konnektivität ohne Sonderwünsche gefragt ist, dann ist 6RD wiederum vollkomen ausreichend.

Die nachfolgenden Informationen stellen eine Aufarbeitung frei verfügbarer Informationen aus den Swisscom Labs und der Community dar.
Die unten gezeigte Konfiguration setzt 6RD auf dieselbe Weise um wie die Centro Router. Zwar muss man IPv6 im Kundencenter bislang selbst einschalten, wer jedoch wie in diesem Beispiel seinen eigenen Cisco-Router mit 6RD aufmöbeln möchte, kann hierauf verzichten.

Vom Prinzip her wird einfach ein neues Tunnel-Interface Tunnel1 erzeugt, dem das Swisscom-spezifische 6RD-Prefix 2A02:1200::/28 zugewiesen wird, als Gegenstelle nimmt 193.5.122.254 (bis 8. April 2013) 193.5.29.1 (ab 9. April 2013) (6rd.ip-plus.net) die Funktion des Tunnel Relays wahr.
Ausserdem wird der 6RD-Prefix von Tunnel1 zudem auf den Bezeichner 6RD-SWISSCOM gemappt.

Im Beispiel wird davon ausgegangen, dass das lokale LAN-Interface auf Vlan1 liegt, entsprechend wird dort IPv6 aktiviert, die IPv6-Adresse wird aus dem zuvor erwähntem Prefix-Mapping 6RD-SWISSCOM und der Host-Adresse ::1 kombiniert. Dabei wurde ein /64 Prefix zugewiesen, damit man später noch weitere IPv6 Subnets zuweisen könnte. Wer das nicht vor hat, kann auch direkt den /60 Prefix verwenden, wovon ich allerdings eher abraten würde.

Zum Schluss wird noch eine IPv6 Default Route via 2A02:120C:1057:AFE0:: eingerichtet. Diese Adresse entspricht dem 6RD Gateway (berechnet indem der globale Prefix 2A02:1200::/28 mit der in Hex umgerechneten IPv4-Adresse 193.5.122.254 von 6rd.ip-plus.net kombiniert wird, wer wirklich wissen will wie das geht, kann mich ja fragen).

Zum Schluss wird noch eine IPv6 Default Route via 2A02:120C:1051:D010:: eingerichtet. Diese Adresse entspricht dem 6RD Gateway (berechnet indem der globale Prefix 2A02:1200::/28 mit der in Hex umgerechneten IPv4-Adresse 193.5.29.1 von 6rd.ip-plus.net kombiniert wird, wer wirklich wissen will wie das geht, kann mich ja fragen).

Hier also die relevante Konfiguration (gültig bis 8. April 2013):



ipv6 general-prefix 6RD-SWISSCOM 6rd Tunnel1
!
interface Tunnel1
description Swisscom 6RD Tunnel to Local LAN
no ip address
no ip redirects
ipv6 enable
ipv6 mtu 1480
tunnel source GigabitEthernet0.10
tunnel mode ipv6ip 6rd
tunnel 6rd prefix 2A02:1200::/28
tunnel 6rd br 193.5.122.254
!
interface Vlan1
description Local LAN
ipv6 enable
ipv6 address 6RD-SWISSCOM ::1/64
!
ipv6 route ::/0 Tunnel1 2A02:120C:1057:AFE0::
!



Und hier die Konfiguration für den neuen Border-Relay, gültig ab 9. April 2013:


ipv6 general-prefix 6RD-SWISSCOM 6rd Tunnel1
!
interface Tunnel1
description Swisscom 6RD Tunnel to Local LAN
no ip address
no ip redirects
ipv6 enable
ipv6 mtu 1480
tunnel source GigabitEthernet0.10
tunnel mode ipv6ip 6rd
tunnel 6rd prefix 2A02:1200::/28
tunnel 6rd br 193.5.29.1
!
interface Vlan1
description Local LAN
ipv6 enable
ipv6 address 6RD-SWISSCOM ::1/64
!
ipv6 route ::/0 Tunnel1 2A02:120C:1051:D010::
!


Wie man sieht braucht's also eigentlich gar nicht viel, damit das zum Fliegen kommt.

Mit dem Befehl show tunnel 6rd kann verifiziert werden, ob der Tunnel zum 6RD-Gateway aufgebaut wurde.
Als Tunnel Source wird die IPv4-Adresse von Interface Gig0.10 ausgewiesen.
Unter General Prefix ist der vom 6RD Gateway zugewiesene IPv6 Prefix ausgewiesen, der zugleich auf 6RD-SWISSCOM gemappt wird.


#sh tunnel 6rd
Interface Tunnel1:
Tunnel Source: 188.63.nnn.nn1
6RD: Operational, V6 Prefix: 2A02:1200::/28
V4 Prefix, Length: 0, Value: 0.0.0.0
V4 Suffix, Length: 0, Value: 0.0.0.0
Border Relay address: 193.5.29.1
General Prefix: 2A02:120B:C3F7:8D0::/60


Man beachte auch, dass ein /60 Prefix zugewiesen wird, was der enorm grossen Anzahl von 295'147'905'179'352'830'000 IPv6-Adressen gleichkommt.
Wow, fast 300 Trillionen (!) IPv6-Adressen für zu Hause! ;-)
Man kann das natürlich auch subnetten, z.B. in 16 * /64 Prefixe, wovon jeder immer noch rund 18.5 Trillionen Adressen umfasst. Wie oben erwähnt, habe ich dem LAN-Interface ein /64 zugewiesen, wonach noch 15 weitere solcher Netze für Tests und anderweitige Spielereien zur Verfügung stehen.

Einen kurzen Verbindungstest schadet auch nicht, beispielsweise indem man die Public IPv6-Adresse von www.heise.de anpingt:



Wenn der Cisco mal soweit eingerichtet ist, geht's mit dem Clients weiter.
Dies würde jetzt allerdings etwas weit führen, ausserdem gehe ich davon aus, dass sich die potentiellen Leser dieses Beitrag bereits soweit mit IPv6 auskennen, dass die Client-Konfiguration die geringste aller Schwierigkeiten sein dürfte ;-)
Powered by [ Universal Post Manager ] plugin. HTML saving format developed by gVectors Team www.gVectors.com